IMPORTANT ALL MEMBERS

All members need to read the following page The new General Data Protection Regulations 2018 (GDPR)

Failure to read and accept the new privacy policy may result in your account being deleted, so please take a quick read

Cheers

The UK-Polos.NET Admin Team

[Solved] Dim/flickering instrument warning lights - Polo 9N1

Discuss In Car Electronics / Electrical Systems - use with caution!
Post Reply
LeonRL
New
Posts: 2
Joined: Tue Jan 20, 2015 8:31 pm
Drives: 2003 9N1 1.9SDi

[Solved] Dim/flickering instrument warning lights - Polo 9N1

Post by LeonRL » Tue Jan 20, 2015 8:48 pm

Hey guys!


Really hoping there's a guru out there can help me out with this.


I currently own a 2003 VW Polo 9N1 with a 1.9 litre SDI engine that I'm trying to sell. Unfortunately, my airbag, ESP and ABS warning lights have all come on, which renders are car unsalable.

After having run a diagnostic scan, there are no errors to be found on any of the systems - the car doesn't even have ESP! The lights are all very dim, sometimes barely visible, and will flicker intermittently. Whether it's relevant or not, I don't know, but the issue started with the airbag light, moved over to the ESP light, and finally tonight, ABS as well. In the beginning, it was predominantly the airbag light that played up, but now the ESP light has taken that role. The ABS light has only come on once or twice, but like the other two, is very dim and flickers. As stated earlier, I have read out the error codes and there are none to be found on any of the relevant systems.

Normally, one would send this out to be repaired at someone who specialized in this sort of thing. Unfortunately, this is not an option for me. I live in a tiny country, surrounded by ocean, car parts are scarce and inflation makes them extremely expensive.


Does anyone know a remedy for this? To me, this seems like a grounding issue, but that is an unqualified guess.


If it's of any help or clarification, it's this type of instrument cluster.

Image

I've also recorded a small video displaying the flashing ESP light.

https://www.youtube.com/watch?v=Ixf8sUnWS3o

Thanks!

Edit: Figured out the issue!

After searching extensively for solutions and coming up with no answers, I, in frustration, decided to removed the cluster from the car, disassembled it and have a look at the circuit board myself. After inspecting it for quite some time, I noticed there was some brown residue around some of the soldering points. I couldn't tell whether it was due to heat or corrosion, but it's definitely been either.

I then dabbed 98% rubbing alcohol on some paper towel and started rubbing it on the affected soldering points. After cleaning all of the affected areas, I let it sit and dry for an hour or so and then refitted it to the car. I can now happily inform the next victim of this stupid error, that it has worked flawlessly. I haven't had a single warning light come on since I did this repair and I'm keeping my fingers crossed!

Good luck!

Polo14
New
Posts: 1
Joined: Tue Jan 12, 2016 10:02 pm
Drives: Polo 9N 2003 1.4 75HK
Location: Denmark

Re: [Solved] Dim/flickering instrument warning lights - Polo 9N1

Post by Polo14 » Tue Jan 12, 2016 10:12 pm

Finally someone with the exact same issue!

I have an issue on my Polo 9N 1.4 75HP where the airbag light is flickering sometimes during the "airbag light session", when you turn the ignition on, and sometimes doesn't lit up at all. Got a MOT-faliure for this lovely issue.

I've tried to clean the rear of the cluster, but haven't taken the dials off. Did you do that as well?

Post Reply