6R Cruise Control Retrofit Problems

Chat about your 6R/6C model Polos here!
User avatar
ciclo
Bling Bling Diamond Member
Posts: 3277
Joined: Sun Feb 24, 2013 10:20 am
Drives: 6R TSI R-line ☺ '13
Location: Earth ♥, Spain ☼
Contact:

Re: 6R Cruise Control Retrofit Problems

Post by ciclo » Fri Feb 17, 2017 7:08 am

Yes, but it is not the same to cross the wire through one hole than the other ... :mrgreen:
Hmm... BCM or glovebox? it's easier via glovebox side (like gannu -RHD-).

However, the best hole and ORIGINAL it is like firegrafik did it, by the firewall bulkhead where is the full harness that goes to engine vain. You can be sure of that.

User avatar
S0K0L
New
Posts: 24
Joined: Fri Jan 20, 2017 11:12 am
Drives: Polo 6R - 2009
Location: Krizevci-Croatia

Re: 6R Cruise Control Retrofit Problems

Post by S0K0L » Tue Feb 21, 2017 7:41 pm

Hello! :)

Tomorrow is "D" day of coding in VCDS my Trip Computer and Cruise Control! :lol: I hope everything will work! :roll:

In the meantime, my friend bought Polo 6C 1.2TSI "FRESH" equipment pack, he liked my car and decided to buy the same :mrgreen: but he beat me and bought newer. :evil:
We talked about my retrofit and Trip Computer, and he told me he also don't have Trip Computer and Cruise control. To me it was strange to not have Trip Computer in this equipment pack but 0k.

Another friend have 6C 1.2TSI "LOUNGE" equipment pack and he has "some" Trip Computer, without buttons on right stalk, just over radio Composition colour?
Image

Is possible to "unlock" somehow this option in 6C "FRESH"? Here are pic's
In menu he have these option's
Image
but submenu is blocked
Image
radio model and software is
Image

I know it is wrong topic for that question but could not find any topic with this kind of "Trip Computer" :(

User avatar
ciclo
Bling Bling Diamond Member
Posts: 3277
Joined: Sun Feb 24, 2013 10:20 am
Drives: 6R TSI R-line ☺ '13
Location: Earth ♥, Spain ☼
Contact:

Re: 6R Cruise Control Retrofit Problems

Post by ciclo » Wed Feb 22, 2017 7:23 am

S0K0L wrote:Hello! :)

Tomorrow is "D" day of coding in VCDS my Trip Computer and Cruise Control! :lol: I hope everything will work! :roll:
To encode the ECU, engine must be OFF.

User avatar
S0K0L
New
Posts: 24
Joined: Fri Jan 20, 2017 11:12 am
Drives: Polo 6R - 2009
Location: Krizevci-Croatia

Re: 6R Cruise Control Retrofit Problems

Post by S0K0L » Thu Feb 23, 2017 5:28 pm

Hi! :D

At last I'm finished with installation of my CCS and Trip computer! :D At same time it was funny, serious and painful experience with happy end! :lol:

I have to thank everyone on forum, especially to mr. ciclo! :D

Image

Now I must find next project! :mrgreen:

User avatar
ciclo
Bling Bling Diamond Member
Posts: 3277
Joined: Sun Feb 24, 2013 10:20 am
Drives: 6R TSI R-line ☺ '13
Location: Earth ♥, Spain ☼
Contact:

Re: 6R Cruise Control Retrofit Problems

Post by ciclo » Thu Feb 23, 2017 5:40 pm

Congrats mate! 8)

kartsan
New
Posts: 7
Joined: Mon Jul 31, 2017 10:08 pm
Drives: Transporter T5
Location: Finland

Re: 6R Cruise Control Retrofit Problems

Post by kartsan » Mon Jul 31, 2017 10:30 pm

Hello sirs,

Excellent forum. I found this via Google while looking for some information about my CC retrofit issue. The original author of this thread had the similar issue like I have now.

My car is Transporter T5 which seems to share a lot of electronics with Polo. BCM's are the same and CC retrofit wiring looks the same. I personally bought VAG original CC retrofit kit which has the instructions, cable and stalk. I did everything according to the instructions, enabled CC with VCDS on BCM and ECU and guess what? It doesn't work.

I get the following errors from ECU. Sorry for giving only pictures, I was lazy because my diagnostic machine does not have Internet.

Image
Image

I get that error immediately, I don't need to touch the stalk at all.

My engine is 2.0TDI (CAAB). I wonder if anyone could check what is the used ECU pin for CC? Is it 64 like stated in the beginning of this thread?

Another thing I don't get. If I go to Central Electronics with VCDS, then Advanced Measuring Values and look for cruise values, Main Switch shows Not Installed all the time? Pic here:

Image

All other signals show change when I move CC main switch from OFF to ON and push SET buttons up and down.

Is this like it should be or not? I did check my wiring once (except the ECU wire) and everything looks ok.
Last edited by kartsan on Tue Aug 01, 2017 10:03 am, edited 1 time in total.

User avatar
iichel
Platinum Member
Posts: 1916
Joined: Fri Nov 14, 2014 2:14 pm
Drives: 6R becoming 6C. slowly.
Location: Zurich, Switzerland

Re: 6R Cruise Control Retrofit Problems

Post by iichel » Tue Aug 01, 2017 6:46 am

Your photos don't work but we're happy to help.
Can you maybe show the instructions too, so we can see what you did. And maybe a VCDS autoscan?

kartsan
New
Posts: 7
Joined: Mon Jul 31, 2017 10:08 pm
Drives: Transporter T5
Location: Finland

Re: 6R Cruise Control Retrofit Problems

Post by kartsan » Tue Aug 01, 2017 10:10 am

Sorry about the pics, I tried something too fancy and failed. Should work now?

I'll run VCDS autoscan and upload it here.

This PDF seems to be a copy of my instructions that I used. I'm not 100% sure about the relay though. There were three relays, two of them were for high current. I used the lower current relay. All of them appeared to key-switch 12V.

One question more: My ECU seems to be chiptuned by a previous owner. Does that have some effect to cruise? I read from somewhere that in an older ECU, retrofit cruise failed due to that. He had the car in VAG service and CC started to work.
Last edited by kartsan on Tue Aug 01, 2017 11:44 am, edited 1 time in total.

User avatar
iichel
Platinum Member
Posts: 1916
Joined: Fri Nov 14, 2014 2:14 pm
Drives: 6R becoming 6C. slowly.
Location: Zurich, Switzerland

Re: 6R Cruise Control Retrofit Problems

Post by iichel » Tue Aug 01, 2017 11:20 am

Thanks, the pictures now work.
Concerning the chiptuning, that really depends how the tuner did his/her job. If he/she only adapted some core fields, no problem. If he/she did a sloppy job, CC might be broken.

PS, I like the dare of VW Teesside, to claim exclusive rights for the PDF guide while taking all the images and descriptions straight from ELSA (VWs own program) and/or the OEM installation guide (part number 7E0 012 175) :mrgreen:
It's not like they made the guide...

kartsan
New
Posts: 7
Joined: Mon Jul 31, 2017 10:08 pm
Drives: Transporter T5
Location: Finland

Re: 6R Cruise Control Retrofit Problems

Post by kartsan » Tue Aug 01, 2017 11:48 am

iichel wrote:
Tue Aug 01, 2017 11:20 am
PS, I like the dare of VW Teesside, to claim exclusive rights for the PDF guide while taking all the images and descriptions straight from ELSA (VWs own program) and/or the OEM installation guide (part number 7E0 012 175) :mrgreen:
It's not like they made the guide...
To me that PDF looks like its VAG part is scanned from a copy of the same paper document I have. In any case, I agree. :D

User avatar
iichel
Platinum Member
Posts: 1916
Joined: Fri Nov 14, 2014 2:14 pm
Drives: 6R becoming 6C. slowly.
Location: Zurich, Switzerland

Re: 6R Cruise Control Retrofit Problems

Post by iichel » Tue Aug 01, 2017 12:22 pm

okay, awaiting autoscan.

Scotty_boy vw
New
Posts: 11
Joined: Tue Jul 25, 2017 11:46 am
Drives: 2015 white 1ltr tsi bluemotion
Location: Dundee

Re: 6R Cruise Control Retrofit Problems

Post by Scotty_boy vw » Tue Aug 01, 2017 12:42 pm

Has anyone on this forum retro fitted cruise control on a 6C polo?

The one with the steering wheel buttons for the cruise control!!!

cheers

scott

User avatar
iichel
Platinum Member
Posts: 1916
Joined: Fri Nov 14, 2014 2:14 pm
Drives: 6R becoming 6C. slowly.
Location: Zurich, Switzerland

Re: 6R Cruise Control Retrofit Problems

Post by iichel » Tue Aug 01, 2017 3:41 pm

Scotty_boy vw wrote:
Tue Aug 01, 2017 12:42 pm
Has anyone on this forum retro fitted cruise control on a 6C polo?

The one with the steering wheel buttons for the cruise control!!!

cheers

scott
I don't know anyone that performed this retrofit successfully. You'll need an activation code from the dealership to make this work.

kartsan
New
Posts: 7
Joined: Mon Jul 31, 2017 10:08 pm
Drives: Transporter T5
Location: Finland

Re: 6R Cruise Control Retrofit Problems

Post by kartsan » Tue Aug 01, 2017 5:09 pm

iichel wrote:
Tue Aug 01, 2017 12:22 pm
okay, awaiting autoscan.
Ok, here we go. My VCDS has a nasty issue to fail loading ASAM files sometimes. In this scan it succeeded when logging engine. I guess the other parts don't need it because there are no errors?

Code: Select all

VCDS Version: Release 15.7.1 (x64) Running on Windows 7 x64
Data version: 20150904
www.Ross-Tech.com

Tuesday,01,August,2017,19:01:37:05031

Chassis Type: 7H (6N0)
Scan: 01 03 08 09 15 17 18 19 25 56 69 0B

VIN: WV1ZZZ7HZAH205987   

01-Engine -- Status: Malfunction 0010
03-ABS Brakes -- Status: OK 0000
04-Steering Angle -- Status: OK 0000
08-Auto HVAC -- Status: OK 0000
09-Cent. Elect. -- Status: OK 0000
15-Airbags -- Status: OK 0000
17-Instruments -- Status: OK 0000
18-Aux. Heat -- Status: OK 0000
19-CAN Gateway -- Status: OK 0000
25-Immobilizer -- Status: OK 0000
56-Radio -- Status: OK 0000
69-Trailer -- Status: OK 0000
 
-------------------------------------------------------------------------------
Address 01: Engine (J623-CAAB)       Labels: 03L-906-022-CAA.clb
   Part No SW: 03L 906 022 CD    HW: 03L 907 309 K
   Component: R4 2,0L EDC   X31 9118  
   Revision: 26X31---    Serial number: 00000000000000
   Coding: 0111401A232400080000
   Shop #: WSC 01286 386 08256
   ASAM Dataset: EV_ECM20TDI01103L906022CD 002013
   ROD: EV_ECM20TDI01103L906022CD.rod
   VCID: 69DE258B886A4576EA-803C

2 Faults Found:
4481 - Cruise Control Switch (E45) 
          P0568 00 [032] - Implausible Signal
          Intermittent - Not Confirmed - Tested Since Memory Clear
             Freeze Frame:
                    Fault Status: 00000001
                    Fault Priority: 2
                    Fault Frequency: 1
                    Mileage: 304527 km
                    Date: 2087.14.18
                    Time: 02:57:42

4482 - Function Restriction due to Implausible Message(s) 
          U1112 00 [039] - -
          Not Confirmed - Tested Since Memory Clear
             Freeze Frame:
                    Fault Status: 00000001
                    Fault Priority: 2
                    Fault Frequency: 3
                    Mileage: 304527 km
                    Date: 2087.14.18
                    Time: 02:57:31

Readiness: 0 0 0 0 X 

-------------------------------------------------------------------------------
Address 03: ABS Brakes (-----)       Labels: 7E0-907-37x-MK25AXT.clb
   Part No SW: 7E0 907 379 E    HW: 7E0 907 379 E
   Component: ESP MK25A XT  H43 0103  
   Revision: 00H43001    
   Coding: 708724AD89A40E9A24AB9179696510
   Shop #: WSC 02736 790 49152
   VCID: 346084FF9728C89E89-8060

No fault code found.

-------------------------------------------------------------------------------
Address 08: Auto HVAC (J301)       Labels: 7E5-907-047.clb
   Part No SW: 7E5 907 047 Q    HW: 7E5 907 047 Q
   Component: Climatic-T5   H10 0101  
   Revision: 00004001    
   Coding: 0000000002
   Shop #: WSC 02737 790 50316
   ASAM Dataset: EV_ClimaticT5 A01002
   ROD: EV_ClimaT5Basis_VN75.rod
   VCID: 3D76A1DBAC6209D676-8068

No fault code found.

-------------------------------------------------------------------------------
Address 09: Cent. Elect. (J519)       Labels: 7H0-937-08x-09.clb
   Part No SW: 7H0 937 087 D    HW: 7H0 937 087 
   Component: BCM T5GP H+4  H47 0221  
   Revision: BO047001    Serial number: 0347 151100001
   Coding: A0B079382E212012002800003C2B84940000410F60040000300000000000
   Shop #: WSC 02754 790 12345
   VCID: 3566B9FB9C52D196BE-8060

   Subsystem 1 - Part No SW: 7E0 959 801     HW: 7E0 959 801   Labels: 7E0-959-801.CLB
   Component: J386__TSG_FT  002 0301 
   Coding: 000000

   Subsystem 2 - Part No SW: 7E0 959 802     HW: 7E0 959 802   Labels: 7E0-959-802.CLB
   Component: J387__TSG_BT  002 0305 
   Coding: 000000

   Subsystem 3 - Part No SW: 3C8 959 537 D    HW: 3C8 959 537 D  Labels: 3C8-959-537.CLB
   Component: E221__MFL-TK6  H07 0022 
   Coding: E20000

No fault code found.

-------------------------------------------------------------------------------
Address 15: Airbags (J234)       Labels: 5K0-959-655.clb
   Part No SW: 7E0 959 655 A    HW: 7E0 959 655 A
   Component: VW10Airbag00N H05 0011  
   Revision: --------    Serial number: 003E50006NJR
   Coding: 00000000000000000000000000000000304E
   Shop #: WSC 02736 790 50316
   ASAM Dataset: EV_IarbaVW10BPAVN750 A01001
   ROD: N/A
   VCID: 346084FF9F28C89E89-8060

No ASAM data for: "EV_IarbaVW10BPAVN750" (VN75) 
No fault code found.

-------------------------------------------------------------------------------
Address 17: Instruments (J285)       Labels: 5K0-920-xxx-17.clb
   Part No SW: 7E0 920 860 A    HW: 7E0 920 860 A
   Component: KOMBI         H15 0111  
   Serial number: 00000000000000
   Coding: 160800
   Shop #: WSC 02736 790 50316
   ASAM Dataset: EV_Okmbi_UDS_VDD_RM09 A04041
   ROD: N/A
   VCID: 26446EB759F4AA0E07-8072

No ASAM data for: "EV_Okmbi_UDS_VDD_RM09" (VW36 *) 
No fault code found.

-------------------------------------------------------------------------------
Address 18: Aux. Heat        Labels: None
   Part No: 7E5 815 071 D
   Component: J737Z_Standmeizung% 0404  
   Revision: 00085050    Serial number: 0<019275A00000
   Coding: 0000031
   Shop #: WSC 68293 788 00000
   VCID: 2B529F838A169766D8-807E

No fault code found.

-------------------------------------------------------------------------------
Address 19: CAN Gateway (J533)       Labels: 6N0-909-901-6R.clb
   Part No SW: 6N0 909 901     HW: 7H0 937 087 
   Component: GW-K-CAN TP20 0221  
   Coding: 042200
   Shop #: WSC 02754 790 12345
   VCID: 70E848EFA3B0B4BEAD-8024

No fault code found.

-------------------------------------------------------------------------------
Address 25: Immobilizer (J334)       Labels: 5K0-920-xxx-25.clb
   Part No SW: 7E0 920 860 A    HW: 7E0 920 860 A
   Component: IMMO          H15 0111  
   Serial number:               
   ASAM Dataset: EV_Immo_USD_VDD_RM09 A03004
   ROD: N/A
   VCID: 26446EB759F4AA0E07-8072

No ASAM data for: "EV_Immo_USD_VDD_RM09" (VW36 *) 
No fault code found.

-------------------------------------------------------------------------------
Address 56: Radio (J503)       Labels: 5M0-035-1xx-56.clb
   Part No SW: 7E0 035 156     HW: 7E0 035 156 
   Component: Radio         H21 0058  
   Revision: R0000000    Serial number: VWZAZ1I9802769
   Coding: 0000020101
   Shop #: WSC 02736 790 12345
   VCID: 60C838AF7350043E3D-8034

No fault code found.

-------------------------------------------------------------------------------
Address 69: Trailer (J345)       Labels: 1K0-907-383-MY8.lbl
   Part No SW: 1K0 907 383 F    HW: 1K0 907 383 F
   Component: ConWysTrailer H07 0100  
   Revision: 3A001001    Serial number: 00000132425721
   Coding: 0100000100000000
   Shop #: WSC 00007 223 174336
   VCID: 306888EF6330F4BEED-8064

No fault code found.

End-------------------------(Elapsed Time: 02:39)--------------------------

User avatar
iichel
Platinum Member
Posts: 1916
Joined: Fri Nov 14, 2014 2:14 pm
Drives: 6R becoming 6C. slowly.
Location: Zurich, Switzerland

Re: 6R Cruise Control Retrofit Problems

Post by iichel » Tue Aug 01, 2017 5:46 pm

As far as I can see, the black-yellow cable must run to the steering column combi switch (2 connectors), to the BCM (1 connector) and ECU (1 connector).

I'm struggling a bit to visualize the e-boxes etc on the T5 GP.
But can you somehow verify that the black-yellow cable goes to the ECU connector, the one with 96 pins, and goes into slot number 64.
--> https://drive.google.com/open?id=0BxYPV ... kh2SkxrYlE

it may be indirectly routed, since I'm not getting this fuse/relay stuff yet.

Post Reply