P0101 code - MAF

Chat about your 6R/6C model Polos here!
BrennB
New
Posts: 29
Joined: Mon Dec 03, 2018 6:29 pm
Drives: Mk8 6r polo
Location: SE Kent

P0101 code - MAF

Post by BrennB »

Hello I have the P0101 code glow plug light showing on dash now and then, Recently had dpf sensor issues so got a new sensor adapted it and all fine until this p0101 code showed up. Got an MOT next week so hoping to sort asap. I changed out the air filter for a brand new one as old was all dirty. MAF sensor looks fine when i unplug it shows on dash plug it back in works fine for around 30-40 miles.. All tubes look fine inspected for cracks maybe an air leak but nothing.. Anyone have an idea what this may be? wiring also looks fine.. Thanks
User avatar
amer6R
Bronze Member
Posts: 228
Joined: Thu Feb 06, 2020 7:57 am
Drives: Polo 6R 2010 1.6 TDI
Location: Balkans

Re: P0101 code - MAF

Post by amer6R »

Clean MAF with brake cleaner,
Maf DTC will pop when you floor it in high gear, low revs
BrennB
New
Posts: 29
Joined: Mon Dec 03, 2018 6:29 pm
Drives: Mk8 6r polo
Location: SE Kent

Re: P0101 code - MAF

Post by BrennB »

I have cleaned MAF with electrical cleaner? Sprayed and also left for a few minutes dried out and re installed making sure everything is sealed but same problem 30-40 miles it comes on again?
User avatar
amer6R
Bronze Member
Posts: 228
Joined: Thu Feb 06, 2020 7:57 am
Drives: Polo 6R 2010 1.6 TDI
Location: Balkans

Re: P0101 code - MAF

Post by amer6R »

What are your live readings while in 4th gear when you floor it. Maf readings?
BrennB
New
Posts: 29
Joined: Mon Dec 03, 2018 6:29 pm
Drives: Mk8 6r polo
Location: SE Kent

Re: P0101 code - MAF

Post by BrennB »

I only have a Autel maxiscan obd2 reader to show me codes I wouldn't know the readings :/ - Its not so much flooring it as it comes on at random? Its come on just sitting there idling in traffic before and other times when im on the motorway 2.5k revs around 70-80mph?
BrennB
New
Posts: 29
Joined: Mon Dec 03, 2018 6:29 pm
Drives: Mk8 6r polo
Location: SE Kent

Re: P0101 code - MAF

Post by BrennB »

If this helps I have also noticed specifically in 3rd gear there seems to be a slugish spot when pulling it dies then picks up again? Could this be related
User avatar
amer6R
Bronze Member
Posts: 228
Joined: Thu Feb 06, 2020 7:57 am
Drives: Polo 6R 2010 1.6 TDI
Location: Balkans

Re: P0101 code - MAF

Post by amer6R »

Go into live data, yes it could be maf related.
Engine- live data
BrennB
New
Posts: 29
Joined: Mon Dec 03, 2018 6:29 pm
Drives: Mk8 6r polo
Location: SE Kent

Re: P0101 code - MAF

Post by BrennB »

Sorry my obd scanner is just a hand held plug in not a vcds laptop or anything like that it only had read codes, erase IM READINESS and thats about it. Doesn't show me any figures
User avatar
amer6R
Bronze Member
Posts: 228
Joined: Thu Feb 06, 2020 7:57 am
Drives: Polo 6R 2010 1.6 TDI
Location: Balkans

Re: P0101 code - MAF

Post by amer6R »

Than if all connections are good, you sprayed cleaner into the connector and have cleaned the MAF, and you still get fault than its dead.
If you have some brake clean try with it, im not sure if eletrical conn. Leaves a thin silicone film.
I have cleaned multiple with brake clean/ carb cleaner, and no issues.
BrennB
New
Posts: 29
Joined: Mon Dec 03, 2018 6:29 pm
Drives: Mk8 6r polo
Location: SE Kent

Re: P0101 code - MAF

Post by BrennB »

Quick update, I have brought a new maf sensor fitted it and still the same issue about 30-40 miles without stopping and then the coil light comes back on with the p0101 code.. I have also noticed sometimes in 3rd gear it’s abit sluggish like dead spot then it pulls once it’s built up which never used to happen.. Any ideas getting sick of this now, thanks
User avatar
amer6R
Bronze Member
Posts: 228
Joined: Thu Feb 06, 2020 7:57 am
Drives: Polo 6R 2010 1.6 TDI
Location: Balkans

Re: P0101 code - MAF

Post by amer6R »

You will have to check the wires and connector. Give them an visual inspection
BrennB
New
Posts: 29
Joined: Mon Dec 03, 2018 6:29 pm
Drives: Mk8 6r polo
Location: SE Kent

Re: P0101 code - MAF

Post by BrennB »

The wires and connector looks fine? Can’t see any tears or problems with them the MAP sensor wouldn’t cause issues would it? As I sometimes have an un even idle or sluggish pulls in gears
User avatar
amer6R
Bronze Member
Posts: 228
Joined: Thu Feb 06, 2020 7:57 am
Drives: Polo 6R 2010 1.6 TDI
Location: Balkans

Re: P0101 code - MAF

Post by amer6R »

What about vacum leaks?
Clean MAP it doesnt hurt. Only benefits
BrennB
New
Posts: 29
Joined: Mon Dec 03, 2018 6:29 pm
Drives: Mk8 6r polo
Location: SE Kent

Re: P0101 code - MAF

Post by BrennB »

I can’t see any leaks no cracks in the air filter box or pipes anywhere, I’m starting to think maybe map as I sometimes have odd idles and sometimes hesitation when pulling away especially in 3rd gear. Anyone know where to locate map sensor on a 6r 1.6 tdi
BrennB
New
Posts: 29
Joined: Mon Dec 03, 2018 6:29 pm
Drives: Mk8 6r polo
Location: SE Kent

Re: P0101 code - MAF

Post by BrennB »

I have noticed my g12 coolant seems to be dropping quite quick.. Any idea on what this could be? Also where would I find the map sensor
Attachments
image.jpg
image.jpg (2.9 MiB) Viewed 161 times
Post Reply