Oil level sensor flashing (yellow) 3 times at ignition on

Chat about your 9n Polo (inc GT and Fun)
Post Reply
littlepolo
Bronze Member
Posts: 205
Joined: Thu Jul 21, 2011 9:47 pm

Oil level sensor flashing (yellow) 3 times at ignition on

Post by littlepolo » Mon Jan 15, 2018 11:56 am

I replaced the oil level sensor last spring due to some issues with the engine which eventually let to a rebuild. The oil level sensor was purchased off eBay (can't recall the brand) and fitted, but it did not solve the problem of three flashes of the yellow lamp at ignition on. This occurs most of the time even though the oil level is OK. I tired the open and close bonnet trick but the problem persists. I suspect it's due to the cheap third-party sensor.

Any recommendations for a replacement (hopefully one that will be a bit cheaper than OEM).

User avatar
alexperkins
Site Admin
Posts: 13947
Joined: Sat Nov 11, 2006 5:29 pm
Drives: 91 Golf GTI, 01 TT 225, 11 Tiguan TDI
Location: Poole, Dorset, UK.
Contact:

Re: Oil level sensor flashing (yellow) 3 times at ignition on

Post by alexperkins » Mon Jan 15, 2018 12:11 pm

A Hella one will be the best choice. They are the same make VW use.

https://www.ebay.co.uk/itm/NEW-OEM-HELL ... Swal5YJccB

littlepolo
Bronze Member
Posts: 205
Joined: Thu Jul 21, 2011 9:47 pm

Re: Oil level sensor flashing (yellow) 3 times at ignition on

Post by littlepolo » Sun Feb 04, 2018 1:54 pm

Oil level sensor replaced with a Hella unit from eBay.

No orange lamp flashing on key on.

Don't really want to test the low oil level sensor.

User avatar
alexperkins
Site Admin
Posts: 13947
Joined: Sat Nov 11, 2006 5:29 pm
Drives: 91 Golf GTI, 01 TT 225, 11 Tiguan TDI
Location: Poole, Dorset, UK.
Contact:

Re: Oil level sensor flashing (yellow) 3 times at ignition on

Post by alexperkins » Sun Feb 04, 2018 1:59 pm

Sounds like it’s fixed 👍🏻

Post Reply