App Connect

Chat about your 6R/6C model Polos here!
Dink
Gold Member
Posts: 835
Joined: Fri Sep 28, 2007 9:04 am
Drives: 2015 GTI
Location: Cwmbran, South wales

Re: App Connect

Post by Dink » Mon Nov 12, 2018 4:58 pm

Yeah that's the cost if you have the option in the menu.

If you don't have the option then it's a case of changing the hardware to one that does have the option.

JDX98
New
Posts: 7
Joined: Sat Nov 10, 2018 8:15 pm
Drives: SE TSI 90 2015
Location: Newcastle upon Tyne

Re: App Connect

Post by JDX98 » Mon Nov 12, 2018 6:37 pm

Thanks Dink for the reply.

What needs to be displayed as the option, MirrorLink?

How easy is it to change the hardware to one that is compatible and rough cost.

Thanks again :)

Dink
Gold Member
Posts: 835
Joined: Fri Sep 28, 2007 9:04 am
Drives: 2015 GTI
Location: Cwmbran, South wales

Re: App Connect

Post by Dink » Mon Nov 12, 2018 7:48 pm

JDX98 wrote:
Mon Nov 12, 2018 6:37 pm
Thanks Dink for the reply.

What needs to be displayed as the option, MirrorLink?

How easy is it to change the hardware to one that is compatible and rough cost.

Thanks again :)
It will say app connect in the menu (mirror link is a waste of time tbh)

It cost me under £200 to get the hardware changed (just the brains in the glove box) and then get it programmed to the car.

JDX98
New
Posts: 7
Joined: Sat Nov 10, 2018 8:15 pm
Drives: SE TSI 90 2015
Location: Newcastle upon Tyne

Re: App Connect

Post by JDX98 » Mon Nov 12, 2018 7:56 pm

Ah I see.

So after the glove box equipment is changed it then would be a further £200 quid or so for activation?

Think I'm getting the gist of it. Either way - its possible pretty much 8)

Dink
Gold Member
Posts: 835
Joined: Fri Sep 28, 2007 9:04 am
Drives: 2015 GTI
Location: Cwmbran, South wales

Re: App Connect

Post by Dink » Mon Nov 12, 2018 8:14 pm

Yeah pretty much as that.

I've not got activation of app connect yet but do have the option available now in the menu.

I've not checked the price myself but have read that the price has gone up for activation.

JaegerStriker
Getting There!
Posts: 83
Joined: Fri Feb 26, 2016 8:54 pm
Drives: 6C GTI
Location: Stockton-on-tees

Re: App Connect

Post by JaegerStriker » Tue Nov 13, 2018 2:58 pm

so atm it seems that app connect gets linked to the vin number. since 2015 polos apparently never came with it as an option then it wont work regardless of swapping out the main unit (glovebox)

still waiting for a reply from vw app connect support germany

Dink
Gold Member
Posts: 835
Joined: Fri Sep 28, 2007 9:04 am
Drives: 2015 GTI
Location: Cwmbran, South wales

Re: App Connect

Post by Dink » Tue Nov 13, 2018 3:38 pm

JaegerStriker wrote:
Tue Nov 13, 2018 2:58 pm
so atm it seems that app connect gets linked to the vin number. since 2015 polos apparently never came with it as an option then it wont work regardless of swapping out the main unit (glovebox)

still waiting for a reply from vw app connect support germany
See that's crazy as app connect works while component protection is enabled.

The app connect is just an FeC that gets switched on when connected to the vw database.

bzzzracing
New
Posts: 3
Joined: Tue Nov 13, 2018 5:18 pm
Drives: 6C
Location: Skipton

Re: App Connect

Post by bzzzracing » Tue Nov 13, 2018 9:11 pm

This week I have been fitting a new Head Unit to my 2015 Polo in order to get the App Connect menu option and connect my iPhone to get Apple Car Play so I can use Google Maps & Spotify.

My Polo was registered 31-3-2015
Has Composition Media (820A) and multi-function steering wheel. Display has Mute Button bottom left hand corner but steering wheel has a Voice button as well as the usual volume and track buttons. It also has a USB port in front of the gear stick.

Worked out that I needed 3Q0035842B which I bought from VW Main Dealer (it was made by Delphi) which they had taken out of a 2017 Tiguan that they had upgraded to NAV. They said it would need de-coding but no mention of whether they had changed it to a 'Virgin' component.

Last night I removed the old Head Unit from the Glovebox and swapped it for the 842B. I then switched the Display on and it worked. I then connected my iPhone via the USB socket and it recognised the phone and activated Apple Car Play. All the Apps worked as expected (Spotify, Messages, Google Maps). All the buttons worked on the steering wheel including Voice Control, volume, skips tracks etc.. All going smoothly.

After 10 minutes the Display then when into Component Protection Mode which was what I expected. I'm also expecting to have to pay for the privilege of activating App Connect which is Part Number 5G0054830A (CIRCA £200 and requires the VW to register something on the VW Server against the Car's VIN. I'm guessing it is just another PR Code (see below)?

Today I went into my Main Dealer to see if they would remove the Component Protection. They said yes and quoted 30 mins. 3.5 hours later they admitted defeat and said that the car kept on throwing error messages which they couldn't clear e.g. ABS Warning Lights, Tyre Pressure Monitor etc. They told me that they spent time on the phone to 'Head Office' but no joy. They told me that the Head Unit is not compatible with my car. Clearly this cannot be true as it worked perfectly for 10 mins and then the sound board was deactivated as expected because of Component Protection kicking in.

I've spoken to a few local experts who say they can remove Component Protection and also 'give it a go' to get everything working.

I'm not wanting to spend another 3 hours with someone giving a go without knowing exactly what they should be doing in the first place. I've looked at the various forums and think it must be something to do with the PR Codes that are associated with the car and sit against the cars VIN Number on a VW Server not being the correct ones for the new head unit to work (software speaking rather than hardware). Anybody know what PR Codes should be added to the car to make the 842B work? My car has the following:

1AZ = Electronic stabilization program (ESP)
CU8 = Alloy wheels 6J x 15
H8D = Tires 185/60 R15 H
4KC = Side and rear windows in heat-insulatingglass
3NC = Rear seat bench/backrest, split folding
2ZH = Leather multi-function steering wheel
Q1A = Standard front seats
J0S = Battery 320A (59Ah)
8K1 = Separate daytime running lights
8M1 = Rear window wiper and washer system with intermittent control
8ID = Halogen twin headlights
U0L = Instrument insert with tachometer clock and mph speedometer
8RL = 6 speakers (passive)
8TD = Rear fog light for driving on the left
I8E = Standard radio (Gen2)
M5F = 4-cylinder gasoline eng. 2.0 L/83 kW w/ activ. charcoal canister, electr. fuel inj., base engine is T5E

If anybody can help me solve this it would be great.

JaegerStriker
Getting There!
Posts: 83
Joined: Fri Feb 26, 2016 8:54 pm
Drives: 6C GTI
Location: Stockton-on-tees

Re: App Connect

Post by JaegerStriker » Fri Nov 16, 2018 9:58 am

try emailing these

Carnet-support@volkswagen.de

thats who i was told to contact to try and see if they can help get it working

bzzzracing
New
Posts: 3
Joined: Tue Nov 13, 2018 5:18 pm
Drives: 6C
Location: Skipton

Re: App Connect

Post by bzzzracing » Fri Nov 16, 2018 10:49 am

Thanks for suggestion. Have already e-mailed them and waiting for a response. Cheers.

JaegerStriker
Getting There!
Posts: 83
Joined: Fri Feb 26, 2016 8:54 pm
Drives: 6C GTI
Location: Stockton-on-tees

Re: App Connect

Post by JaegerStriker » Sat Nov 24, 2018 12:12 pm

ive had my replies from vw. basically it should work but it is down the the technicians to be able to figure it out.

"if you wish to use App Connect, you should visit the dealer of your preference for its installation, should your vehicle be eligible. The fitting of the part comes at an extra cost, for which you should consult with your dealer for further information"

our cars are listed as compatible but there is something stopping the installations

bzzzracing
New
Posts: 3
Joined: Tue Nov 13, 2018 5:18 pm
Drives: 6C
Location: Skipton

Re: App Connect

Post by bzzzracing » Sun Nov 25, 2018 9:17 pm

Unfortunately the technician at my local dealer was unable to figure it out but still charged me for the privilege.

Resseh
New
Posts: 1
Joined: Wed Dec 12, 2018 3:33 pm
Drives: None at moment
Location: Bristol

Re: App Connect

Post by Resseh » Wed Dec 12, 2018 3:35 pm

I’m looking to buy a polo but a lot of salesman don’t know which cars have car play (other than Match Editions should have it)

If I was to buy an R-Line 2016 polo - is that likely to have the ability to have car play?

Many thanks :)

muscles1960
New
Posts: 3
Joined: Sun Dec 02, 2018 3:29 pm
Drives: 1.8 GTI 2017
Location: Staffordshire

Re: App Connect

Post by muscles1960 » Thu Dec 13, 2018 4:17 pm

bzzzracing wrote:
Tue Nov 13, 2018 9:11 pm
This week I have been fitting a new Head Unit to my 2015 Polo in order to get the App Connect menu option and connect my iPhone to get Apple Car Play so I can use Google Maps & Spotify.

My Polo was registered 31-3-2015
Has Composition Media (820A) and multi-function steering wheel. Display has Mute Button bottom left hand corner but steering wheel has a Voice button as well as the usual volume and track buttons. It also has a USB port in front of the gear stick.

Worked out that I needed 3Q0035842B which I bought from VW Main Dealer (it was made by Delphi) which they had taken out of a 2017 Tiguan that they had upgraded to NAV. They said it would need de-coding but no mention of whether they had changed it to a 'Virgin' component.

Last night I removed the old Head Unit from the Glovebox and swapped it for the 842B. I then switched the Display on and it worked. I then connected my iPhone via the USB socket and it recognised the phone and activated Apple Car Play. All the Apps worked as expected (Spotify, Messages, Google Maps). All the buttons worked on the steering wheel including Voice Control, volume, skips tracks etc.. All going smoothly.

After 10 minutes the Display then when into Component Protection Mode which was what I expected. I'm also expecting to have to pay for the privilege of activating App Connect which is Part Number 5G0054830A (CIRCA £200 and requires the VW to register something on the VW Server against the Car's VIN. I'm guessing it is just another PR Code (see below)?

Today I went into my Main Dealer to see if they would remove the Component Protection. They said yes and quoted 30 mins. 3.5 hours later they admitted defeat and said that the car kept on throwing error messages which they couldn't clear e.g. ABS Warning Lights, Tyre Pressure Monitor etc. They told me that they spent time on the phone to 'Head Office' but no joy. They told me that the Head Unit is not compatible with my car. Clearly this cannot be true as it worked perfectly for 10 mins and then the sound board was deactivated as expected because of Component Protection kicking in.

I've spoken to a few local experts who say they can remove Component Protection and also 'give it a go' to get everything working.

I'm not wanting to spend another 3 hours with someone giving a go without knowing exactly what they should be doing in the first place. I've looked at the various forums and think it must be something to do with the PR Codes that are associated with the car and sit against the cars VIN Number on a VW Server not being the correct ones for the new head unit to work (software speaking rather than hardware). Anybody know what PR Codes should be added to the car to make the 842B work? My car has the following:

1AZ = Electronic stabilization program (ESP)
CU8 = Alloy wheels 6J x 15
H8D = Tires 185/60 R15 H
4KC = Side and rear windows in heat-insulatingglass
3NC = Rear seat bench/backrest, split folding
2ZH = Leather multi-function steering wheel
Q1A = Standard front seats
J0S = Battery 320A (59Ah)
8K1 = Separate daytime running lights
8M1 = Rear window wiper and washer system with intermittent control
8ID = Halogen twin headlights
U0L = Instrument insert with tachometer clock and mph speedometer
8RL = 6 speakers (passive)
8TD = Rear fog light for driving on the left
I8E = Standard radio (Gen2)
M5F = 4-cylinder gasoline eng. 2.0 L/83 kW w/ activ. charcoal canister, electr. fuel inj., base engine is T5E

If anybody can help me solve this it would be great.
Try www.vagcarcoding.com - Search on FB.

Ecb
New
Posts: 4
Joined: Tue Apr 16, 2019 9:28 pm
Drives: Polo Match TDI 2017
Location: Inverclyde

Re: App Connect

Post by Ecb » Wed Apr 17, 2019 11:33 am

Wish I had found this earlier!

My 2017 first registered Polo has - 3Q0 035 820 B (Composition Media) which I presume rules out app-connect and likely apple CarPlay. Ho hum, you live and learn.
andraski wrote:
Sat Oct 06, 2018 10:14 am
So let's go to the facts!

My 2015 Polo GTI is an early 2015, so it left the factory before App-Connect was released. In VW words it means my car doesn't have the right head unit and wiring. The truth is that its head unit and USB port are not compatible with App-Connect and its functions (CarPlay and Android Auto).
Just to clarify, the Polo can have various versions of the Composition Media (just radio) or Discover Media (with satellite navigation). Here's a list of all those units:

:( These are NOT compatible with App-Connect:

- 3Q0 035 820 (Composition Media)
- 3Q0 035 820 A (Composition Media)
- 3Q0 035 820 B (Composition Media)
- 3Q0 035 820 C (Composition Media)
- 3Q0 035 842 (Composition Media, can have MirrorLink only)
- 3Q0 035 874 (Discover Media, can have MirrorLink only, it's the one my Polo has)


:D These units are compatible with App-Connect:

- 3Q0 035 842 A (Composition Media)
- 3Q0 035 842 B (Composition Media)
- 3Q0 035 842 C (Composition Media)
- 3Q0 035 874 A (Discover Media)
- 3Q0 035 874 B (Discover Media)
- 3Q0 035 874 C (Discover Media)

The only way to have App-Connect working on a car fitted with the units that are not compatible with it it's to replace the head unit for one of the ones that are compatible. If it left the factory before App-Connect was released (early 2015) you also have to replace the USB port for a newer compatible version. If you want an upgrade from Composition Media to Discover Media you have to replace the screen unit as well.
The real problem is that VW doesn't do that, for them it's straightforward: if your car left the factory after the release of App-Connect you can have it, otherwise they can't help. They can get you a newer head unit but they will not change the USB port to retrofit App-Connect on you vehicle. The only option is this case is to look for external companies that can do the job.

I got the head unit and the USB port of my Polo replaced for a newer version by Satnat Systems, just outside London, in Surbiton. I totally recommend them since they're very professional and extremely polite. You'll only find good reviews about them, no matter where you look. It's a bit pricey but worth the investment (specially if you have the Composition Media and want satellite navigation).

Hopefully this will be helpful to someone in the future.

Cheers

Post Reply