Oil pressure issues

Chat about your 9n Polo (inc GT and Fun)
Post Reply
ConnorRogers
New
Posts: 3
Joined: Wed Aug 14, 2019 11:14 am

Oil pressure issues

Post by ConnorRogers » Wed Aug 14, 2019 11:20 am

VW polo 2003 1.4 petrol

Having an issue where will be driving along and the engine power will suddenly drop for about couple of seconds and then kick back in and run OK. Yesterday was driving along dual carriageway and did it couple of times and then completely died and oil light came on managed to get to layby and restarted the engine and started up fine and ok just with engine management on. Checked oil level today after car has stood overnight and oil is good, had full service last week so filters and oil have been changed, but this problem existed before. Could it be a faulty oil pressure switch? :?:

Many thanks!

littlepolo
Silver Member
Posts: 444
Joined: Thu Jul 21, 2011 9:47 pm

Re: Oil pressure issues

Post by littlepolo » Wed Aug 14, 2019 12:32 pm

Are you able to scan for any codes?

ConnorRogers
New
Posts: 3
Joined: Wed Aug 14, 2019 11:14 am

Re: Oil pressure issues

Post by ConnorRogers » Wed Aug 14, 2019 4:03 pm

I haven't an engine diagnostic tool personally but used a colleagues but this had trouble connecting to the CPU

littlepolo
Silver Member
Posts: 444
Joined: Thu Jul 21, 2011 9:47 pm

Re: Oil pressure issues

Post by littlepolo » Thu Aug 15, 2019 6:20 am

You really need a scan tool/cable that works, otherwise it's guesswork and swapping parts. It could be the oil pressure switch but I've had a fair share of issues with my Polo and never had one fail. There is also an oil level switch but IIRC that just illuminates a warning lamp.

RUM4MO
Bling Bling Diamond Member
Posts: 4237
Joined: Sat Dec 30, 2006 9:12 pm
Drives: B8 S4 & 6R/6C1 1.2TSI 110
Location: Mid Lothian

Re: Oil pressure issues

Post by RUM4MO » Thu Aug 15, 2019 10:11 am

OP, remember one thing, if the engine dies/flames out, the oil pressure light will come on, so maybe you are getting concerned about the wrong things.

I'd hope that if you fix what is causing the intermittent cutting out of the engine, the car will run okay.

ConnorRogers
New
Posts: 3
Joined: Wed Aug 14, 2019 11:14 am

Re: Oil pressure issues

Post by ConnorRogers » Fri Aug 16, 2019 12:43 am

Possibly it's only concerning me as that's the only light that comes on and it beeps at me. I hope so too its a good car just had 2 new tyres and full service. Thanks anyways!

RUM4MO
Bling Bling Diamond Member
Posts: 4237
Joined: Sat Dec 30, 2006 9:12 pm
Drives: B8 S4 & 6R/6C1 1.2TSI 110
Location: Mid Lothian

Re: Oil pressure issues

Post by RUM4MO » Fri Aug 16, 2019 9:53 am

Maybe I misinterpreted what you wrote initially, I thought that you were concerned that the oil light was coming on when the engine was dying, which is expected, if it I is coming on when the engine is running normally, then replace the oil pressure sensor before doing anything else.

Post Reply