Usb issues after full nav media upgrade

Chat about your 6R/6C model Polos here!
Post Reply
Robbo770
New
Posts: 28
Joined: Sat Mar 14, 2020 1:56 am
Drives: Polo SEL 1.4 tdi 2014
Location: Scotland

Usb issues after full nav media upgrade

Post by Robbo770 » Wed Mar 18, 2020 7:43 pm

Hi folks, my polo is first of the 6c’s being a SEL had mib2 installed with Bluetooth and was able to have mirror play.

I replace the display to full nav unit and 874b media unit, now have working Bluetooth, WLAN, phone, voice and Nav just waiting on new map sd card.

The Apple CarPlay is ready to use but it’s not seeing a phone plugged in at the USB socket, think I need to upgrade the socket, maybe the wiring too?


Anyone any advise and part numbers or even if you have the required parts would be great.

Cheers Rob

Robbo770
New
Posts: 28
Joined: Sat Mar 14, 2020 1:56 am
Drives: Polo SEL 1.4 tdi 2014
Location: Scotland

Re: Usb issues after full nav media upgrade

Post by Robbo770 » Sat Mar 21, 2020 4:22 am

So after much trawling I found this great post on another site covering exactly what I need to find out.

If you have a basic 510 stereo system you will need to get the usb cable and new socket for android / CarPlay / mirrorlink when updating the media unit in the glove box

https://www.drive2.com/l/533524549434606087/

Also found this very nice pic for putting usb in the rear

https://images.app.goo.gl/QnVmoLLe8oA49wJa6

Robbo770
New
Posts: 28
Joined: Sat Mar 14, 2020 1:56 am
Drives: Polo SEL 1.4 tdi 2014
Location: Scotland

Re: Usb issues after full nav media upgrade

Post by Robbo770 » Sun Mar 22, 2020 12:42 pm

So I received a new green socket new 2017 version 5Q0035726E in the post yesterday, not facial fitting to try and get my Apple CarPlay working.
FBB06488-1ECB-49E8-A8F9-40EE2ACEF4B6.png
Now my car has mib2 but being 2014 only a red socket fitted when new, not compatible with CarPlay.
So the cable connection is polarised for a red socket by 1 edge preventing fitting to the green socket, bar that identical in wire orientation.

So I trimmed this off to allow trail of the system.....
0D225630-042B-47A8-872D-435E3776554D.jpeg
Red con 1
7E05BA2A-9637-4B49-99B6-50C018AA3563.jpeg
Red con 2
86C194BB-B3D2-45AE-B8AA-749BA914ECC8.jpeg
Red con 3
EFD8CB59-CB9C-47DD-B63C-6A50C5C966A2.jpeg
Red con 4
FF930888-1F04-47B1-AABD-01EBD4C786E5.jpeg
Red con 5
85974A83-028B-4501-A7F5-2C30752AC61A.jpeg
Completed connection
I fired up the car and success! Apple CarPlay fully operational
1C7F3A0A-C804-4494-BE0A-98E81DD4F142.jpeg
Car play
I am awaiting a USB hub to try and expand the usb connections in the car with voltage converter for 3 of them.....
93A92622-DF69-4D61-9360-80E9B49BBA33.jpeg
Usb hub
Don’t know if this will work, but as the interior is current apart fitting this in the rear for power only for the back seats
895679B9-FCF9-4C32-810C-E4030F9BA38B.jpeg
Rear usb hubs
Hoping heated seat kit arrives Monday so I can fit everything all at once :)

Robbo770
New
Posts: 28
Joined: Sat Mar 14, 2020 1:56 am
Drives: Polo SEL 1.4 tdi 2014
Location: Scotland

Re: Usb issues after full nav media upgrade

Post by Robbo770 » Mon Mar 23, 2020 1:14 pm

So the other usb socket arrived today which has the surface mount format.

Decided to compare the 2 units and ends up they have identical inner boards so here is the info in the pics folks for info.
08216F7D-8722-481C-BA93-B1723547DE84.png
E8E206FB-BA93-4C2F-BE3F-BB78DAF61E84.jpeg
6ECACAD7-8DA4-4963-BC98-A9CA16F8DAB5.jpeg
9F54B438-AC20-44DA-A825-EAC0F0A2413D.jpeg

Robbo770
New
Posts: 28
Joined: Sat Mar 14, 2020 1:56 am
Drives: Polo SEL 1.4 tdi 2014
Location: Scotland

Re: Usb issues after full nav media upgrade

Post by Robbo770 » Mon Mar 23, 2020 4:26 pm

Anyone got a 2017 wiring guidance for the usb hub power 4 pin connector?
2E271F2D-2B07-4058-A84F-F9CA69EAD1B3.jpeg
17 3 port hub usb

Robbo770
New
Posts: 28
Joined: Sat Mar 14, 2020 1:56 am
Drives: Polo SEL 1.4 tdi 2014
Location: Scotland

Re: Usb issues after full nav media upgrade

Post by Robbo770 » Tue Mar 24, 2020 1:11 pm

So the hub arrived and this is what it looks like close up
D56C39D6-FC21-40E8-B2A5-7004F45B84F7.jpeg
230A57EF-0458-48D4-A2B9-158C91323CFD.jpeg
AF9A763C-3B5D-427C-86AE-272EC41754CA.jpeg
680783CC-E6A8-4504-A217-5CC6CD130AB1.jpeg

Just need to see if anyone can help work out the 4 pin connections
As this is the only info I have found.....
F6311346-8E8C-4400-80F9-4DCB84DE9750.jpeg

Robbo770
New
Posts: 28
Joined: Sat Mar 14, 2020 1:56 am
Drives: Polo SEL 1.4 tdi 2014
Location: Scotland

Re: Usb issues after full nav media upgrade

Post by Robbo770 » Tue Mar 24, 2020 8:48 pm

So after several hours of travelling the internet I found this which makes more sense,

Pin 1 - 12 volts
Pin 2 - earth ( taken from usb earth feed)
Pin 3 - n/a
Pin 4 - media unit =5 volt ( taken from original usb power feed)
1BC9D691-CF6F-4DF5-9A33-3DE675EDB7D8.jpeg
The unit connections of the actual Fakra ones are
9B9CBC11-6BC5-4F67-92A6-AB52A7B73F70.jpeg
I need to get my hands on 3 A type Fakra 4 pin cables to allow me to plug the 3 socket in.

Robbo770
New
Posts: 28
Joined: Sat Mar 14, 2020 1:56 am
Drives: Polo SEL 1.4 tdi 2014
Location: Scotland

Re: Usb issues after full nav media upgrade

Post by Robbo770 » Tue Mar 24, 2020 9:01 pm

Reason we have to change the usb sockets also now identified, however if a cable mod is done the same sockets also will work
C58C3AB1-E81E-4578-AD0F-060B160558AF.jpeg
Cable mod is to rotate 180 deg and make it refit the plug
8FEAC6F9-3802-43CE-9BC2-B35AB407C4CB.jpeg

andy_256
New
Posts: 2
Joined: Thu Mar 26, 2020 10:36 pm
Drives: Polo 1.0
Location: Birmingham

Re: Usb issues after full nav media upgrade

Post by andy_256 » Thu Mar 26, 2020 10:56 pm

Hi Robbo770


Great post....My son bought his first car recently, a 3 door Polo, and I've treated him to an upgrade of the media unit through Vagtech as he wanted DAB, NAV and Car Play. Had it fitted locally to me with new aerial and leads and all works fine except for Car Play.

Now i've worked out, and you have confirmed that the USB is not active so only charges the phone. I've purchased the correct one, green end, and will be fitting this weekend - that can be my daily exercise. The lead for the socket is purple like yours, are you suggesting that if I adapt it like yours it will work for Car Play, so i don't need to change the lead?

Thanks in advance

Robbo770
New
Posts: 28
Joined: Sat Mar 14, 2020 1:56 am
Drives: Polo SEL 1.4 tdi 2014
Location: Scotland

Re: Usb issues after full nav media upgrade

Post by Robbo770 » Fri Mar 27, 2020 12:52 pm

Hi, correct, trim the tab stopping it fitting the green new usb socket and bingo all will work

JaegerStriker
Bronze Member
Posts: 108
Joined: Fri Feb 26, 2016 8:54 pm
Drives: 6C GTI
Location: Stockton-on-tees

Re: Usb issues after full nav media upgrade

Post by JaegerStriker » Sat Mar 28, 2020 1:07 pm

Robbo770 wrote:
Wed Mar 18, 2020 7:43 pm
Hi folks, my polo is first of the 6c’s being a SEL had mib2 installed with Bluetooth and was able to have mirror play.

I replace the display to full nav unit and 874b media unit, now have working Bluetooth, WLAN, phone, voice and Nav just waiting on new map sd card.

The Apple CarPlay is ready to use but it’s not seeing a phone plugged in at the USB socket, think I need to upgrade the socket, maybe the wiring too?


Anyone any advise and part numbers or even if you have the required parts would be great.

Cheers Rob
where did you get the replacement from, was it full package ie screen and glovebox unit?
was it all CP unlocked?

Robbo770
New
Posts: 28
Joined: Sat Mar 14, 2020 1:56 am
Drives: Polo SEL 1.4 tdi 2014
Location: Scotland

Re: Usb issues after full nav media upgrade

Post by Robbo770 » Mon Mar 30, 2020 1:05 am

I just bought a full nav / voice/ dab/ Bluetooth/ appleplay / mirror play unit from vagnavinfo@gmail.com which with a nav display unit will immediately work with no issues regarding CP.

You might need the vdcs system to be updated for model and rear camera just once all plugged in, start up screen.


Give them an email tell them Rob in aberdeen put you on to them the unit comes with a new GPS aerial that you fit when doing the swap.

Cheers

Post Reply